Rocket

AWS Global Outage Impacting Site Publishing Service
Resolved·Partial outage

AWS Services are restored now, and the Site Publishing Service is now fully operational.

Mon, Oct 20, 2025, 10:35 AM
(1 week ago)
·
Affected components
Published customer sites
Updates

Resolved

AWS Services are restored now, and the Site Publishing Service is now fully operational.

Mon, Oct 20, 2025, 10:35 AM

Identified

We are currently experiencing an outage in our Site Publishing Service due to a global disruption in AWS infrastructure. This issue is causing delays and failures in publishing and updating sites for some users.

Mon, Oct 20, 2025, 09:18 AM(1 hour earlier)
Powered by