Resolved
The issue affecting preview environments for a subset of Rocket.new users has been resolved.
Identified
We are investigating an issue affecting preview environments for a subset of users. Some previews may fail to load or remain inaccessible. Initial investigation suggests the issue may be related to DNS resolution and routing.
Our engineering team is actively diagnosing the problem and working toward a resolution. Other platform functionality remains operational.